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Chapter 1
Introduction toDocumentumComposer

Documentum Composer is the next generation development tool for developing, building, and
installing Documentum applications for Content Server. It is intended to replace DAB/DAI as the
standard tool for developing Documentum applications. These applications specify how Content
Server handles different types of content.

Composer is built on top of the Eclipse platform and provides additional Documentum functionality
in addition to all of the core Eclipse functionality. Composer is shipped in two versions, the UI-based
version with wizards, dialogs, and editors, and a non-UI “headless” Composer that is used for
automating build and deployment.

Composer vs Headless Composer
Composer is available in two separate packages, Composer and headless Composer. Composer has a
user interface and headless Composer is a command line based tool that is driven with Ant tasks.

In general, you should use Composer for normal development activities that require creation or
modification of Composer projects. You should use Headless Composer for automating build and
deployment activities with Ant scripts. Headless Composer does not provide any facilities to develop
Documentum applications. The following table describes some similarities and differences between
the two Composer packages:

Table 1. Composer and Headless Composer Comparison

Features/Functionality Composer Headless Composer

Create new project Yes Yes

Create new artifacts Yes No

Import artifacts from repository Yes Yes

Import DocApps from
repository

Yes No

Import DocApp archives Yes No

Import project from local
directory

Yes Yes

Build project Yes Yes
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Introduction to Documentum Composer

Features/Functionality Composer Headless Composer

Install project Yes Yes

Install DAR file No

Composer lets you install the
project, a process that includes
automatically generating and
installing a DAR file “behind
the scenes”. However, there is
no separate “Install DAR File”
option in Composer.

Yes

Headless Composer lets you
install a DAR file using the
emc.install Ant task.

UNIX and Linux support in Composer
Composer is not supported in UNIX or Linux environments, however, you can use headless
Composer on UNIX and Linux systems to install DAR files to Content Server repositories on UNIX,
Linux, and Windows systems. Only the headless Composer distribution that is bundled with Content
Server is supported in UNIX and Linux environments.

Alternatively, you can use the DAR Installer or headless Composer on Windows systems to install
DAR files to Content Server repositories on UNIX and Linux systems.

See Installing a DAR file with headless Composer on UNIX and Linux systems, page 16 for
information on how to run headless Composer.

6 EMC Documentum Composer Version 6.5 SP3 Quick Start Guide



Chapter 2
Getting Started with Composer

These topics describe how to install Composer and how to create a simple Composer project that
you can install to the repository. It is intended to familiarize you with working with Composer
and its new development paradigm.

Installing Composer
Documentum Composer is packaged as a compressed zip file that contains the Eclipse platform and
all required plugins. Installing Documentum Composer involves unzipping the zip file to a directory
of your choice.

Before installing Composer, ensure that you meet the following prerequisites:

• Documentum 5.3 SP6 or later repositories

• Java JDK 1.5

To install Composer:

1. Extract the content of the DCTM_Composer_<version>.zip file to a directory on your local
machine. A directory named Composer is created.

2. Set the JAVA_HOME environment variable on your local machine to point to your installation of
Java JDK 1.5. For example, if the Java JDK is installed in the C:/Program Files/Java/jdk1.5.0_17
directory, set the JAVA_HOME variable to that path.

3. Edit the <Composer_root>/plugins/com.emc.ide.external.dfc_1.0.0/documentum.config/dfc.
properties file and add the connection broker information, similar to the following:
dfc.docbroker.host[0]=[DocBroker IP address or host name]

4. If you want to work with lightweight SysObjects, you must install the lightweight SysObject
plugin as described in Installing the lightweight SysObject plugin, page 8 .

Configuring the Java JRE and compiler preferences

The installed Java Runtime Environment (JRE) in the Composer preferences must match the Java
Development Environent (JDK) that is configured in the environment variables on the local machine
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that is running Composer. If the JRE does not match, the Composer project may not install correctly
in a repository.

Note: Composer requires JRE 1.5. If your local machine has an earlier JRE version installed, you
must upgrade Java before you proceed.

To configure the Java JRE and compiler preferences:

1. In a command prompt window, enter SET JAVA_HOME to verify the path that is set in the
JAVA_HOME environment variable. The JAVA_HOME variable must point to a JDK 1.5
directory. Your JDK 1.5 directory also contains a JRE directory that you must tell Composer
to use as its runtime.

2. In the Composer main menu selectWindow > Preferences.
The Preferences dialog appears.

3. Click the Java option to expand it, then click Installed JREs. The Installed JREs page appears.

4. If the default installed JRE is not the one that is bundled with your JDK, click Add to add
another JRE.
The Add JRE dialog appears.

5. Click Browse and select the JRE 1.5 directory that came bundled with JDK 1.5, for example
C:/Program Files/Java/jdk1.5.0_17/jre.

6. Click OK to verify that the new JRE is on the Installed JREs page and ensure that it is checked.

7. Select Java >Compiler from the tree on the left and set the Compiler compliance level to 1.5.

8. Click OK to save your changes.

Installing the lightweight SysObject plugin

The lightweight SysObject plugin allows you to work with lightweight SysObjects. It is not part of
the main Composer distribution and must be installed in the <Composer_root>/plugins directory
after you have installed Composer.

To install the lightweight SysObject plugin:

1. Download the LightweightObject_<version>.zip file from the download site
(http://emc.subscribenet.com)

2. Extract the plugin to the same directory as Composer. For example, if you extracted Composer to
the C:\ directory, you also need to extract the LightweightObject_<version>.zip file to the C:\
directory.

3. Change to the<Composer_root>/plugins directory and verify that the com.emc.ide.artifact.
lwdclass_1.0.0.jar and com.emc.ide.artifact.lwdclass_ui_1.0.0.jar files are in the directory.
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Creating a Composer project
A Composer project is a logical container for your Documentum artifacts. You cannot work with
Documentum artifacts outside the context of a Composer project. To get started with Composer,
create a Composer project that contains a custom Documentum type:

1. Start Composer, by running <Composer_root>\eclipse.exe. TheWorkspace Launcher window
appears, which allows you to specify a workspace to save your Composer projects.

2. In theWorkspace field, specify a directory for your workspace.

3. Select the Use this as the default and do not ask again checkbox if you want to use the same
workspace for all of your projects. You can always create new workspaces or switch between
workspaces later. When the workspace is created succesfully, Composer launches.

4. Click the File > New > Project... menu item, select Documentum Project > Documentum Project,
and click Next.

5. In the Project Name field, typeHelloComposer and click Finish. Composer takes a few moments
to create the project.

6. If you are prompted to switch to the Documentum Artifacts perspective, click Yes. This
perspective enables features that are useful in creating Documentum applications.

Your new project appears in the Documentum Navigator view of Composer.

Creating an artifact
All Documentum artifacts must be created within a Composer project. You will now create a type
artifact that you can assign repository objects to. The type subtypes dm_document and inherits
dm_document’s attributes. You will add one custom attribute to your custom type.

To create the type artifact:

1. In the Documentum Navigator view, right click the HelloComposer > Artifacts > Types folder
and select New > Other.... The New wizard appears.

2. Select Documentum Artifact > Type from the list and click Next.

3. In the Artifact name field, type my_custom_type and click Finish.

4. On the General tab, click Select... for the Supertype field, select dm_document from the list, and
click OK. Your type now inherits the attributes of dm_document.

5. On the Attributes tab, click New and select newattribute1 from the list on the left. Custom
attributes allow you to define metadata to describe your object that aren’t already inherited
from dm_document.

6. In the Structure section, specify the following for the fields:
• Name - my_custom_attr

• Data type - STRING

• Length - 20

EMC Documentum Composer Version 6.5 SP3 Quick Start Guide 9



Getting Started with Composer

7. Click File > Save or type Ctrl+S to save the type.

Installing the Composer project
Now that you have created a type in a Composer project, you can install the project to a repository.
After installation, you can assign Documentum objects to this type in the repository.

To install the project:

1. In the Documentum Navigator view, right-click the InsuranceApp project and click Install
Documentum Project.... The Install Wizard appears.

2. Fill in the required information for the repository and credentials for that repository and click
Login. If the login is successful, the Next button is enabled. If the Next button is not enabled,
verify your login credentials and try again. Click Next to continue to the Edit Installation
Parameter File Values screen.

3. You will not specify any installation parameters. Click on Finish to install the application to the
repository. If no errors are returned, your application installed correctly. You can now utilize
the custom type.

Installing a DAR file with the DAR Installer
A DAR file is a deployable, package representation of a Composer project. You can use the DAR
Installer to install a DAR file to a repository if you do not want to use the interface within Composer.
The DAR Installer requires Composer to be installed, but does not launch the full Composer IDE.

The DAR Installer is useful for installing Documentum product DAR files or in cases where you want
to decouple the development of DAR files from the installation of DAR files. When you open the
DAR Installer, it creates three folders in your Composer installation directory:

• darinstallerconfig — contains configuration files for the DAR Installer Plugin

• darinstallerlogs — the default location of the log files

• darinstallerworkspaces — workspaces that are created and used by the DAR Installer
Plugin. The DAR Installer does not delete these workspaces automatically after
installation of the DAR file. The workspace directories are named in the following form:
darinstaller_workspace_yyyy-mm-dd-hh-mm-ss. Moving, deleting, or adding projects manually
to the workspace might have adverse effects on DAR installations.

Note: If the DAR file that you are installing depends on other reference DAR files, you must install
those reference DAR files first. If the DAR file that you are installing depends on reference DAR files
that you have already installed, you need to have all of the reference DAR files in the same directory
as the DAR file that you want to install. Ensure that any required DAR files are the correct version
and contain the necessary artifacts.

The DAR Installer requires you to fill in certain values that are marked with an asterisk (*). All other
fields are optional. For a description of the fields for the DAR Installer plugin, see Table 2, page 11.
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To install a DAR file:

1. Run darinstaller.exe, which is located in the Composer root directory, to start the DAR Installer.

2. In the DAR Details section, specify values for the fields.

3. In the Connection Broker Details section, specify values for Connection Broker Host and
Connection Broker Port and click Connect.

4. In the Repository Details section, specify values for the fields and click Install to install the
DAR file to the repository.

You can view the log for the DAR installation by selecting the log file from the Log File drop down
menu and clicking Open.

Table 2. DAR Installer fields

Parameter Required Description

DAR Yes The absolute file path to the
.dar file that you want to install.
The file path cannot contain
any I18N characters or the
installation will fail.

Input File No The absolute file path to the
install-based parameter file

Local Folder No The absolute file path to
localized .properties files.
If you want to make your
application available in other
languages, you need to localize
the project data such as labels,
tabs, and descriptions.

Log File No The file to save the log to. If this
is not specified, the file defaults
to <DAR>.log

Connection Broker Host Yes The address of the Connection
Broker

Connection Broker Port Yes The port of the Connection
Broker Repository

Repository Yes The name of the repository that
you want to install the DAR file
to. Click on the Connect button
after entering the Docbroker
host and port to retrieve the
available repositories.

User Name Yes The login name for the
repository
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Parameter Required Description

Password Yes The password for logging into
the repository

Domain No The domain of the user
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Chapter 3
Getting Started with headless
Composer

Headless Composer is a separate package from UI Composer. It is used for automated build and
deployments of Composer projects through a set of Ant tasks.

The headless Composer Ant tasks allow you to:
• Import a project

• Create a project

• Import artifacts into a project

• Update content within a JAR Definition or Procedure

• Build a project

• Generate a DAR file

• Install a DAR file

Installing headless Composer
Headless Composer is distributed in a different zip file than the UI-based Composer package.

To install headless Composer:

1. Extract the headless Composer zip file to a directory on your local machine. The directory
name must not contain any spaces. The headless Composer zip file has the format
DCTM_Headless_Composer_<platform>_<version>.zip.

2. Edit the <Composer_root>/plugins/com.emc.ide.external.dfc_1.0.0/
documentum.config/dfc.properties file and add the connection broker information,
similar to the following:

dfc.docbroker.host[0]=[DocBroker IP address or host name]

3. Save your changes.
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Creating a headless Composer build
A headless Composer build allows you to automate the build and installation of Composer projects.
A headless Composer build consists mainly of two parts: Ant scripts that define the build and a batch
file that sets up the build environment and runs the Ant scripts.

Creating Ant scripts to build, modify, and install
Composer projects

Ant scripts are XML files that define your build. Composer provides Ant tasks that allow you to call
certain Composer functionality from the Ant scripts.

In general, you should create two separate Ant build files that build your projects and install your
projects. The Ant scripts should be encoded in UTF-8 to ensure proper functionality.

To create the Ant scripts:

1. Create a file named build.xml.

2. Create a target to import the projects that you want to work with into the headless Composer
workspace with the emc.importProject task. You can also create new projects with the
emc.createArtifactProject task.

3. Optional: Make any modifications that you want to the project with the emc.importArtifacts or
emc.importContent tasks.

4. Create a target to build the project with the emc.build task.

5. Create a target to generate the DAR file with the emc.dar task.

6. Create a file named install.xml.

7. Create a target to install the DAR file with the emc.install task.

Example 3-1. Example build.xml file

<?xml version="1.0"?>
<project name="headless-example" default="package-project">
<target name ="import-project" description="Must import a project before updating,
building, or installing it">
<emc.importProject
dmproject="HelloWorldBOFModule"
failonerror="true"/>

</target>

<target name="update-jardef" depends="import-project" description="Update JARDef
with most current JAR file">
<emc.importContent
dmproject="HelloWorldBOFModule"
artifactpath="Artifacts/JAR Definitions/helloworldjardef.jardef"
contentfile="build_workspace/HelloWorldBOFModule/bin-impl/HelloWorld.jar" />

</target>

<target name="build-project" depends="update-jardef" description="Build the project">
<emc.build
dmproject="HelloWorldBOFModule"
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failonerror="true"/>
</target>

<target name="package-project" depends="build-project"
description="Package the project into a DAR for installation">
<delete file="HelloWorld.dar" />
<emc.dar
dmproject="HelloWorldBOFModule"
manifest="bin/dar/default.dardef.artifact"
dar="HelloWorld.dar" />

</target>

</project>

Example 3-2. Example install.xml file

<?xml version="1.0"?>
<project name="headless-install" default="install-project">
<target name="install-project" description="Install the project to the specified
repository. dfc.properties must be configured">
<emc.install
dar="HelloWorld.dar"
docbase="GlobalRegistry"
username="Administrator"
password="emc"
domain="" />

</target>
</project>

Creating a batch file to setup and run the build

The batch file is used to configure the environment variables and workspaces on your local machine,
and calls the Ant scripts that contain the import, build, or install instructions for your build.

The following example batch file does the following actions:
• Defines the Eclipse directory path to be at C:\ComposerHeadless

• Creates two workspaces, one for importing and building a project (BUILDWORKSPACE) and one
for installing the resulting DAR file (INSTALLWORKSPACE),

• Specifies the location of the build and installation scripts: build.xml and install.xml.

• Cleans the workspaces

• Copies the Composer projects into the build workspace

• Runs the build and installation scripts

Example 3-3. Example batch file

REM Set environment variables to only apply to this command prompt
SETLOCAL

REM Sets the root location of headless Composer.
SET ECLIPSE="C:\ComposerHeadless"

REM Sets the location of your source projects.
REM This location gets copied into your build workspace directory.
SET PROJECTSDIR="C:\Documents and Settings\Administrator\composer-workspace"
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REM Sets the workspace directory where Composer builds the projects
REM that you want to install to a repository.
SET BUILDWORKSPACE="C:\ComposerHeadless\example build\build_workspace"

REM Sets the workspace directory where Composer extracts built DAR files before
REM installing them to a repository.
SET INSTALLWORKSPACE="C:\ComposerHeadless\example build\install_workspace"

REM Sets the Ant script that builds your projects
SET BUILDFILE="C:\ComposerHeadless\example build\build.xml"

REM Sets the Ant script that installs your projects
set INSTALLFILE="C:\ComposerHeadless\example build\install.xml"

REM Delete old build and installation workspaces
RMDIR /S /Q %BUILDWORKSPACE%
RMDIR /S /Q %INSTALLWORKSPACE%

REM Copy source projects into build workspace
XCOPY %PROJECTSDIR% %BUILDWORKSPACE% /E

REM Run Ant scripts to build and install the projects
JAVA -cp %ECLIPSE%\startup.jar org.eclipse.core.launcher.Main -data
%BUILDWORKSPACE% -application org.eclipse.ant.core.antRunner -buildfile %BUILDFILE%
JAVA -cp %ECLIPSE%\startup.jar org.eclipse.core.launcher.Main -data
%INSTALLWORKSPACE% -application org.eclipse.ant.core.antRunner -buildfile %INSTALLFILE%

The two JAVA commands should be declared on one line. The example splits the command into two
lines for readability.

Installing a DAR file with headless Composer on UNIX
and Linux systems

Headless Composer is supported on UNIX and Linux systems only if you use the distribution that is
bundled with Content Server. Headless Composer on UNIX and Linux can be used to install a DAR
file to UNIX, Linux, or Windows systems. Any other function is not supported.

Scripts are provided for setting up the environment and installing the DAR file if you do not want to
go through the trouble of creating your own deployment scripts. To install a DAR file with headless
Composer on UNIX and Linux systems:

1. Login to the Content Server system as the owner of the repository that you want to install the
DAR file to.

2. Ensure that your environment variables are set according to the Content Server deployment
guide. Most notably, run the $DM_HOME/bin/dm_set_server_env.sh shell script to set the
environment variables

3. Run the following command to install a DAR file, replacing the variables with the appropriate
values for your environment:
$JAVA_HOME/bin/java -Ddar=$PATH_TO_DAR_FILE -dlogpath=$PATH_TO_LOG_FILE
-Ddocbase=$REPOSITORY_NAME -Duser=$REPOSITORY_SUPER_USER
-Ddomain=$REPOSITORY_USER_DOMAIN -Dpassword=$PLAIN_TEXT_PASSWORD
-cp $DM_HOME/install/composer/ComposerHeadless/startup.jar
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org.eclipse.core.launcher.Main -data $DM_HOME/install/composer/
workspace -application org.eclipse.ant.core.antRunner -buildfile
$DM_HOME/install/composer/deploy.xml

Note: If you are installing a DAR file that depends on other reference DAR files, you must install the
reference DAR files first and in the same Ant script as the DAR file that you want to install. You must
do this even if you previously installed the reference DAR files.
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Chapter 4
Important Composer features and
concepts

The following topics describe common features and concepts of Composer that are helpful to any
user of Composer.

Project and DAR installation
Composer provides a few options regarding installation of your Documentum applications. You can
install your Composer projects directly from Composer, export your Composer projects to DAR files
and install them with the DAR installer, or install your projects through an automated headless
Composer deployment.

In any case, it is important to understand installation considerations when installing your Composer
projects or DAR files.

Installation with Composer - Composer only supports installation of Composer projects. Using
Composer for installation is best for developers who want to develop and install their applications
from the same interface.
• If your Composer project requires it, ensure that all of its reference projects are properly
designated. If you do not designate all of the appropriate reference projects, the installation of
your project will fail.

• Composer automatically builds DAR files for your Composer projects by default. You can obtain
them in the <Composer_project_root>/bin-dar directory. However, you cannot install DAR files
with Composer. Only Composer projects can be installed with Composer.

Installation with the DAR Installer - The DAR Installer is a standalone UI that comes packaged with
Composer. It allows you to decouple the development and installation of Composer projects, which
is useful if you want an administrator to oversee installations of applications or if you want to install
applications at a later time and do not want to start the full Composer IDE.
• The DAR Installer is not suitable for installing many DAR files at once as it is an interactive
tool without any batch installation features.

• If the DAR file that you are installing depends on other reference DAR files, you must install
those reference DAR files first. If the DAR file that you are installing depends on reference DAR
files that you have already installed, you need to have all of the reference DAR files in the same
directory as the DAR file that you want to install. Ensure that any required DAR files are the
correct version and contain the necessary artifacts.
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Installing DAR files with headless Composer - Headless Composer allows you to automate project
installation through the use of Ant. Headless Composer provides Ant targets for common Composer
build tasks. You can install DAR files and Composer projects with headless Composer.

• When installing DAR files, all reference DAR files must be installed with the emc.install task
before installing the DAR file even if the reference DAR files have previously been installed.
The emc.install tasks for the required DAR files must be declared within the same script as the
emc.install task for the DAR that you want to install. All the tasks must be ran in the same call to
Ant. Ensure that any required DAR files are the correct version and contain the necessary artifacts.

• When installing a Composer project, all necessary reference projects must be imported with the
emc.import task before installation of the project.

• Headless Composer is supported under UNIX and Linux if you are using the distribution that is
bundled with the Content Server installation package.

Composer reference projects
Composer lets you create references between projects. This is useful if you have projects that share
resources such as Documentum artifacts, libraries. or JAR files. You can specify reference projects
when you create a new project or by editing an existing project.

In general, you can designate any project as a reference project if it has resources that you want to
share with other projects. Documentum also supplies special reference projects that allow you to
access Documentum functionality.

Documentum supplied reference projects

Documentum supplied reference projects are non-buildable projects that you need if you want to
use or extend Documentum artifacts (more specifically, Documentum artifacts with names that
begin with ’dm’).

Every project that you create within Composer has the DocumentumCoreProject designated as
a reference project by default. The DocumentumCoreProject contains all of the artifacts that are
provided by Content Server, so you can use or extend these artifacts out of the box. The project is
read only and should not be modified. It is marked with the icon and is displayed only in the
Package Explorer view, and not the Documentum Navigator view.

If you need to use or extend an artifact from another Documentum product, obtain the reference
project that contains the artifacts that you want to use. The various Documentum products supply
their Composer reference projects in their respective download areas on EMC’s software download
site, https://emc.subscribenet.com.

It is useful to know the following points, which will help you understand when you need to
download and reference a Documentum supplied reference project:

• Your Composer project cannot contain artifacts with names that begin with ’dm’. ’Dm’ is a
reserved prefix for Documentum. Because ’dm’ is a reserved prefix, ’dm’ artifacts that are present
in user projects are detected as errors by Composer. A ’dm’ artifact, however, can exist in
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Documentum supplied reference projects, such as DocumentumCoreProject. This provides you
with a mechanism to use and extend ’dm’ artifacts.

• You can use or extend any ’dm’ artifact that is provided by Content Server without needing to
download a separate reference project, because the DocumentumCoreProject is already provided
and referenced for your convenience. You need to obtain the reference projects for all other ’dm’
artifacts that are not provided by Content Server (for example, Taskspace ’dm’ artifacts).

• If you import an artifact from the repository, it might depend on other artifacts to function. If these
other artifacts are not present in your project or in reference projects, Composer automatically
imports these artifacts from the repository. If the automatically imported artifacts have names that
begin with ’dm,” it will cause the following error:

“Type name is invalid. Type names must not begin with ’dm’. For more information, see the
’Reference projects’ section in the Composer User Guide.”

If this error occurs, delete the newly imported artifacts, import and designate the appropriate
projects as reference projects, and re-import the desired artifacts.

• If you import an artifact that indirectly references a ’dm’ artifact, you still need to import the
project that contains the ’dm’ artifact and designate it as a reference project. For example, if you
are importing a type named my_child_type that depends on a type named my_parent_type that
depends on a ’dm’ type, then you must download the project that contains the ’dm’ type, import it
into your workspace, and designate it as a reference project.

• The previous points also apply to converting DocApps and DocApp archives as well. If the
DocApp or DocApp archive uses or extends ’dm’ artifacts that are not in DocumentumCoreProject,
you must import all required Documentum supplied reference projects into your workspace
before converting the DocApp or DocApp archive. During the conversion, Composer will prompt
you to specify the necessary reference projects.
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Chapter 5
Frequently Asked Composer Questions

General Questions
• Can I use Composer 6.5 with a Documentum 6.0 or 5.3 repository?

Yes, you can use Composer 6.5 with a Documentum 6.0 or 5.3 repository as long as you are not
trying to install BPM artifacts or artifacts that leverage new Documentum functionality, such as
Smart Container (introduced after Documentum 6.0) or Aspects (introduced after Documentum
5.3). The latest version of Composer supports Documentum versions 5.3 SP6 and later.

• Can I use Composer to migrate cabinets, folders, or content from one repository to another?

We don’t recommend using Composer in this fashion because Composer was designed for
application development and not data migration. Therefore, if you have a lot of cabinets, folders,
and content, we cannot guarantee good migration performance. If the folders and content
are related to application development and setup, such as an XML Application Folder with
supporting documents, it is acceptable to import those into a Composer project.

• Do you offer Composer as a set of plugins so that I can install Composer plugins on top of my
version of Eclipse?

No, for supportability reasons and ease of installation, Composer is only available as an entire
package with Eclipse embedded in it.

• Do you support Linux or Solaris?

We support using headless Composer on Linux and Solaris with a caveat. We do not ship a
separate version of Composer for Linux or Solaris. The Content Server Installer includes a version
of headless Composer that has been configured with the correct environment variables for these
two operating systems.

• What is a Documentum supplied reference project? Why do I need it?

Documentum supplied reference projects are non-buildable projects that allow you to use or
extend artifacts whose names begin with ’dm’ (Documentum artifacts). Composer does not allow
you to have ’dm’ artifacts in your projects to prevent unintentional changes to Documentum
artifacts in the repository. You must designate the appropriate reference project to use or extend
a ’dm’ artifact.

• Can I install individual artifacts?

Currently, artifacts must be installed as part of a Composer project.

• Do you support uninstallation of Composer Projects or DARs?

No, because Content Server does not support the uninstallation of certain artifacts such as Types.
If you’re in a development environment where you can experiment, we recommend you use
VMWare so you can roll back any changes.

• Can I still use Docbasic pre- and post-install scripts?
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Yes, pre- and post-install scripts are specified in the Documentum Project Properties. To specify
the scripts, right-click the Composer project in the Documentum Navigator, select Properties,
then go to the Documentum Project > Install Procedures section.

• Can I use Composer to develop applications for the High-Volume Server?

Yes, a Lightweight SysObject Object Plugin is provided as a separate download that you can
install on top of Composer.

• How do I find out the version of Composer I am running?

Open the <Composer_root>\plugins\com.emc.ide.external.dfc_1.0.0\documentum.
config\version.properties file to see the version number. For instance, if you see the line
"current.build.version=6.5.0.024" you have Composer 6.5.

DAR Files
• What is a DAR?

A DAR file is a packaged output file of a Composer project. It contains artifacts that you install
it to a repository with the DAR Installer plugin or headless Composer, but does not contain the
source code for the artifacts. An analogy would be a JAR file compared to Java source code. A
DAR file is the Composer equivalent to a DAB DocApp archive.

• How do I install DAR files?

Use the DAR Installer or headless Composer with Ant tasks. The Composer UI cannot install
DAR files.

• My DAR installation fails with the error "Unzipped resource must exist (<artifact path\artifact
name>).” What is wrong?

The unzipped artifact file path length has exceeded the allowed length in Windows. You can
reduce the file path length by installing Composer to the system root folder or to a folder that
doesn’t have a long path.

• I try to launch the DAR Installer UI by running darinstaller.exe and I get errors. What’s wrong?
— You do not have a compatible Java environment installed or JAVA_HOME is not set. You
can check this by running the ’java -version’ command on the command line. If the system
does not recognizes the java command or the version is not 1.5, install Java 1.5 and set the
JAVA_HOME environment variable to point to the Java installation.

— The darinstallerstartup.jar file is missing in the Composer directory or darinstaller.exe is
running from a wrong directory. You must run darinstaller.exe from the Composer root
folder. If darinstallerstartup.jar is missing, reinstall Composer. The following command
either starts the DAR Installer or produces an error.from the: java \-cp darinstallerstartup.jar
com.emc.ide.installer.darinstaller.starter.DarInstallerStarterMain.

Lifecycles and Workflows
• How do I validate lifecycles?
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In DAB, you could explicitly invoke a menu item to validate a lifecycle. In Composer, lifecycles
are validated automatically at install time. There is no need to manually validate a lifecycle
in Composer. If the lifecycle fails validation, an error is displayed and the installation of the
Composer project fails.

• How do I uninstall lifecycles?

We do not support uninstallation of lifecycles, but we do support deactivating a lifecycle. To
deactivate a lifecycle, check the "Inactivate lifecycle" checkbox that is in the Overview tab in the
Properties window and re-install the Composer project.

• How do I create Workflow templates in Composer?

Composer does not have a workflow editor integrated into the IDE. The Workflow Manager tool
is included with Composer and is located in the <Composer_root>\WorkflowManager directory.

• Can I import Workflow templates into Composer?

Workflow templates and BPM process templates are based on the same infrastructure. We chose
to use BPM terms in the Composer UI. If you use Composer and try to import individual artifacts
from the repository, select the Artifact type to be "Process Template", and your workflow template
should show up. The steps to import an individual workflow template/BPM process template are:
1. Right click on a Composer Project and select Import....

2. Go to Documentum -> Artifacts From Repository.

3. Enter repository credentials.

4. In the Artifact Type dropdown, select Process Template.

• I want to import a workflow template into Composer with the intention of migrating the template
from a development environment to a QA environment. When I install the template, should I
choose version or overwrite as an installation option?

Documentum does not have an overall best practice for this situation. The two options are
described in the following list:
— Overwrite - Documentum overwrites the existing workflow template in the target
environment. This means that any workflow that is in process will be affected by the new
workflow template. You have to decide whether or not this is appropriate for your use case.

— Version - Documentum versions the existing workflow in the target environment. Workflows
that are in process will use the old version of the workflow while any newly created workflow
processes will use the new template. The default behavior in Documentum is to overwrite.

• Composer seems to import incorrect versions of workflow and form templates. Sometimes it
imports the latest installed version and sometimes it imports a draft version. What’s going on?

Composer will always pull the CURRENT version of a workflow or form template. We do not
look at the status of the object (Draft, Installed, etc.) If your goal is to always pull the latest
installed version, then it is up to your developers to ensure that the latest installed version has
the CURRENT label.

• I have a sizeable TaskSpace Application that includes five workflow templates, 20-30 form
templates, and 20-30 UI templates. Each workflow template has hundreds of activities. Does
Documentum have any best practices around structuring the Composer Projects? Should it be one
Composer project or multiple Composer projects?
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From a performance standpoint, it makes no difference whether it is multiple Composer projects,
or one large Composer project because the total number of installed artifacts remains the same.

However, there could be advantages to having multiple Composer projects, depending on the
way you develop applications. For example, if you expect that a certain workflow will change
frequently, then it may be a good idea to have that workflow in a separate Composer project. That
way, you can install the workflow without having to re-install the entire TaskSpace application.

We suggest that you start Composer with a sufficiently large maximum heap size. You can change
the heap size by opening the <Composer_root>/eclipse.ini file and editing the ’-Xmx’ option.
Change the value to 1024m if it is not already set. The option should look like ’-Xmx1024m’
when you are done editing.

Composer vs DAB/DAI
• What is the difference between Composer and DAB/DAI?

DAB/DAI is an MFC-based application that was used to configure Documentum artifacts.
Composer is intended to replace DAB/DAI and is built on top of the Eclipse infrastructure.

• Why do I need to use Composer? Why can’t I keep using DAB/DAI?

In the near future, DAB/DAI will go through the end-of-life process.

• Can I use DocApps and DARs interchangeably? Can I use Composer and DAB/DAI
interchangeably?

No, you cannot use DocApps and DARs interchangeably. It is recommended that you switch to
Composer as soon as it is feasible.

• I’m trying to convert my DocApp. What is a migration repository?

In Composer, the process for converting a DocApp archive involves installing the DocApp archive
to a repository, then creating a Composer project based on the installed DocApp. A migration
repository is the repository where you’d like to install the DocApp archive. As a best practice, this
migration repository should be one where the DocApp archive has not been installed previously,
and none of the artifacts that are contained in the DocApp archive should exist in the repository.

• Can I migrate from a 5.3SPx DocApp to a 6.5 Composer project?

Yes, you can go straight from 5.3 SPx to 6.5.
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