Jenkins Update Version 1.562 vers 1.563

De EjnTricks

Hand-icon.png Votre avis

Nobody voted on this yet

 You need to enable JavaScript to vote


System-Install-icon.png Download-icon.png Téléchargement et installation

#sudo service tomcat6 stop
#sudo rm -rf /var/lib/tomcat6/webapps/jenkins/*
#sudo wget -P /var/lib/tomcat6/webapps http://mirrors.jenkins-ci.org/war/1.563/jenkins.war
#sudo unzip /var/lib/tomcat6/webapps/jenkins.war -d /var/lib/tomcat6/webapps/jenkins
#sudo chown -R tomcat6:tomcat6 /var/lib/tomcat6/webapps/jenkins
#sudo rm -rf /var/lib/tomcat6/work/Catalina/localhost/jenkins
#sudo rm /var/lib/tomcat6/webapps/jenkins.war


Update icon.png Plugin-icon.png Plugins

Il semblerait que les plugins ne se mettent pas à jour automatiquement sur la machine d'étude. Ceux ci sont donc installés manuellement en fonction de la page de mise à jour. La description des plugins est disponibles depuis l'adresse: http://updates.jenkins-ci.org/update-center.json. Sur la machine, les plugins suivants doivent être mis à jour:


A noter, certains plugins sont dans le coeur de jenkins, d'autre disponible dans le répertoire d'extensions.

#sudo rm /var/lib/tomcat6/webapps/jenkins/WEB-INF/plugins/credentials.hpi
#sudo wget -P /var/lib/tomcat6/webapps/jenkins/WEB-INF/plugins http://updates.jenkins-ci.org/download/plugins/credentials/1.10/credentials.hpi
#sudo rm /var/lib/tomcat6/webapps/jenkins/WEB-INF/plugins/ldap.hpi
#sudo wget -P /var/lib/tomcat6/webapps/jenkins/WEB-INF/plugins http://updates.jenkins-ci.org/download/plugins/ldap/1.9/ldap.hpi
#sudo rm /var/lib/tomcat6/webapps/jenkins/WEB-INF/plugins/matrix-auth.hpi
#sudo wget -P /var/lib/tomcat6/webapps/jenkins/WEB-INF/plugins http://updates.jenkins-ci.org/download/plugins/matrix-auth/1.2/matrix-auth.hpi
#sudo rm /var/lib/tomcat6/webapps/jenkins/WEB-INF/plugins/matrix-project.hpi
#sudo wget -P /var/lib/tomcat6/webapps/jenkins/WEB-INF/plugins http://updates.jenkins-ci.org/download/plugins/matrix-project/1.0/matrix-project.hpi
#sudo rm -rf /var/lib/tomcat6/webapps/jenkins/WEB-INF/plugins/ssh-credentials.hpi
#sudo wget -P /var/lib/tomcat6/webapps/jenkins/WEB-INF/plugins http://updates.jenkins-ci.org/download/plugins/ssh-credentials/1.6.1/ssh-credentials.hpi
#sudo rm /var/lib/tomcat6/webapps/jenkins/WEB-INF/plugins/ssh-slaves.hpi
#sudo wget -P /var/lib/tomcat6/webapps/jenkins/WEB-INF/plugins http://updates.jenkins-ci.org/download/plugins/ssh-slaves/1.6/ssh-slaves.hpi
#sudo rm /var/lib/tomcat6/webapps/jenkins/WEB-INF/plugins/subversion.hpi
#sudo wget -P /var/lib/tomcat6/webapps/jenkins/WEB-INF/plugins http://updates.jenkins-ci.org/download/plugins/subversion/2.4/subversion.hpi
#sudo rm /var/lib/tomcat6/webapps/jenkins/WEB-INF/plugins/translation.hpi
#sudo wget -P /var/lib/tomcat6/webapps/jenkins/WEB-INF/plugins http://updates.jenkins-ci.org/download/plugins/translation/1.11/translation.hpi
#sudo chown tomcat6:tomcat6 /var/lib/tomcat6/webapps/jenkins/WEB-INF/plugins/credentials.hpi
#sudo chown tomcat6:tomcat6 /var/lib/tomcat6/webapps/jenkins/WEB-INF/plugins/ldap.hpi
#sudo chown tomcat6:tomcat6 /var/lib/tomcat6/webapps/jenkins/WEB-INF/plugins/matrix-auth.hpi
#sudo chown tomcat6:tomcat6 /var/lib/tomcat6/webapps/jenkins/WEB-INF/plugins/matrix-project.hpi
#sudo chown tomcat6:tomcat6 /var/lib/tomcat6/webapps/jenkins/WEB-INF/plugins/ssh-credentials.hpi
#sudo chown tomcat6:tomcat6 /var/lib/tomcat6/webapps/jenkins/WEB-INF/plugins/ssh-slaves.hpi
#sudo chown tomcat6:tomcat6 /var/lib/tomcat6/webapps/jenkins/WEB-INF/plugins/subversion.hpi
#sudo chown tomcat6:tomcat6 /var/lib/tomcat6/webapps/jenkins/WEB-INF/plugins/translation.hpi


Bug-icon.png Problèmes post installation

Le plugin Subversion Plugin est mis à jour avec la version 2.4. Cependant, au démarrage de Jenkins, un message d'erreur est affiché dans la console de sortie.

Grave: Failed Loading plugin subversion
java.io.IOException: Dependency mapdb-api (1.0.1.0) doesn't exist
        at hudson.PluginWrapper.resolvePluginDependencies(PluginWrapper.java:488)
        at hudson.PluginManager$2$1$1.run(PluginManager.java:356)
        at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
        at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
        at jenkins.model.Jenkins$7.runTask(Jenkins.java:904)
        at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
        at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
        at java.lang.Thread.run(Thread.java:745)

Le plugin n'est alors pas chargé et l'ensemble des projets basés sur un gestionnaire de source SVN devient inopérationnel. Dans la page d'administration, l'utilisateur est informé de variables de configuration illisibles, toutes celles du plugin SVN, avec les messages :

CannotResolveClassException: hudson.scm.SubversionTagAction,
CannotResolveClassException: hudson.scm.SVNRevisionState,
CannotResolveClassException: hudson.scm.SubversionChangeLogParser
CannotResolveClassException: hudson.scm.SubversionSCM

La page officiel du plugin confirme le message d'erreur, à savoir une nouvelle dépendence sur le plugin mapdb-api. Celui-ci va être téléchargé et installé comme tous les autres plugins.

#sudo wget -P /usr/share/tomcat6/.jenkins/plugins http://updates.jenkins-ci.org/download/plugins/mapdb-api/1.0.1.0/mapdb-api.hpi
#sudo chown tomcat6:tomcat6 /usr/share/tomcat6/.jenkins/plugins/mapdb-api.hpi